Posture
which-devices-or-software-are-eol.kql
Devices running at least one end-of-support / end-of-life software title or version, from `DeviceTvmSoftwareInventory`.
// Author: Ian D. Hanley (DevSecOpsDad) | linkedin.com/in/ianhanley | devsecopsdad.com | devsecopsdadattack.com
// Devices that have at least one end-of-support (EOL/EOS) title or version
DeviceTvmSoftwareInventory
| where isnotempty(DeviceName)
| where isnotempty(EndOfSupportDate) and EndOfSupportDate <= now()
| project DeviceName, SoftwareName, SoftwareVersion, SoftwareVendor, EndOfSupportDate
| order by DeviceName asc, SoftwareName asc
DeviceTvmSoftwareInventory
| where isnotempty(DeviceName)
| where isnotempty(EndOfSupportDate) and EndOfSupportDate <= now()
| summarize
EOLSoftwareCount = count(),
EOLSoftwareList = make_set(SoftwareName, 100),
OldestEOLDate = min(EndOfSupportDate)
by DeviceName
| order by EOLSoftwareCount desc