Who Deleted An AD User


Who deleted an AD user (`SecurityEvent` EventID `4726`) over the last 90 days.

KQL Library  /  Identity

 Identity who-deleted-an-ad-user.kql

Who deleted an AD user (`SecurityEvent` EventID `4726`) over the last 90 days.

Tactics Impact
Techniques T1531
Platforms Windows
Deep Dive  Deep Dive
// Author: Ian D. Hanley (DevSecOpsDad) | linkedin.com/in/ianhanley | devsecopsdad.com | devsecopsdadattack.com
// Source: KQL Toolbox #6: From Junk Clicks To Identity & Privilege Control (2026-01-31) — https://www.hanley.cloud/2026-01-31-KQL-Toolbox-6-From-Junk-Clicks-to-Identity-%26-Privilege-Control/
// Tactics: Impact
// Techniques: T1531
// Platforms: Windows
// Data: SecurityEvent
SecurityEvent
| where TimeGenerated > ago (90d)
| where EventID == "4726"
| extend Actor_ = Account
| project-reorder TimeGenerated, Activity, Actor_, TargetUserName, Computer